团体天梯练习 L2-026 小字辈
L2-026 小字辈
本题给定一个庞大家族的家谱,要请你给出最小一辈的名单。
输入格式:
输入在第一行给出家族人口总数
输出格式:
首先输出最小的辈分(老祖宗的辈分为
输入样例:
9
2 6 5 5 -1 5 6 4 7
输出样例:
4
1 9
解题思路
题目大致意思就是求出树上层次最大的一层的所有节点,然后对这些节点按照编号排个序输出。方法很明显是
/* 一切都是命运石之门的选择 El Psy Kongroo */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<deque>
#include<stack>
#include<map>
#include<set>
#include<bitset>
#include<cmath>
#include<functional>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<int, pii> piii;
typedef pair<double, double> pdd;
typedef pair<string, int> psi;
typedef __int128 int128;
#define PI acos(-1.0)
#define x first
#define y second
//int dx[4] = {1, -1, 0, 0};
//int dy[4] = {0, 0, 1, -1};
const int inf = 0x3f3f3f3f, mod = 1e9 + 7;
const int N = 1e5 + 10;
int h[N], e[N], ne[N], idx;
vector<int> res;
int n, root, level;
void add(int a, int b){
e[idx] = b, ne[idx] = h[a], h[a] = idx ++ ;
}
void bfs(){
queue<int> q;
q.push(root);
while(!q.empty()){
res.clear();
int nn = q.size();
while(nn -- ){
int u = q.front();
q.pop();
res.push_back(u); //记录当前层的节点
for(int i = h[u]; i != -1; i = ne[i]){
int v = e[i];
q.push(v);
}
}
level ++ ;
}
//最后结束循环时,res中存储的就是最后一层的所有节点
}
int main(){
ios::sync_with_stdio(false);
cin.tie(0), cout.tie(0);
memset(h, -1, sizeof(h));
cin >> n;
for(int i = 1; i <= n; i ++ ){
int fa; cin >> fa;
if(fa != -1) add(fa, i);
else root = i;
}
bfs();
cout << level << endl;
sort(res.begin(), res.end());
for(int i = 0; i < (int)res.size() - 1; i ++ ) cout << res[i] << ' ';
cout << res.back();
return 0;
}
一切都是命运石之门的选择,本文章来源于博客园,作者:MarisaMagic,出处:https://www.cnblogs.com/MarisaMagic/p/17331848.html,未经允许严禁转载
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· AI技术革命,工作效率10个最佳AI工具