团体天梯练习 L2-005 集合相似度
L2-005 集合相似度
给定两个整数集合,它们的相似度定义为:$ N_{c} / N_{t} × 100 $ %。其中 \(N_{c}\) 是两个集合都有的不相等整数的个数,\(N_{t}\) 是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。
输入格式:
输入第一行给出一个正整数 \(N\)(≤50),是集合的个数。随后 \(N\) 行,每行对应一个集合。每个集合首先给出一个正整数 \(M\)(≤ \(10^{4}\)),是集合中元素的个数;然后跟 \(M\) 个 \([0, 10^{9}]\) 区间内的整数。
之后一行给出一个正整数 \(K\)(≤2000),随后 \(K\) 行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。
输出格式:
对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。
输入样例:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
输出样例:
50.00%
33.33%
解题思路
水题,其实就是求两个集合的交集大小,用 \(STL\) 库中的 set_intersection 即可,不过要熟悉一下用法。 \(N_{c}\) 即为每次询问的两个集合的交集的大小,\(N_{t}\) 即为两个集合的大小之和减去这个交集的大小,注意一下输出格式即可。
/* 一切都是命运石之门的选择 El Psy Kongroo */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<deque>
#include<stack>
#include<map>
#include<set>
#include<bitset>
#include<cmath>
#include<functional>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<int, pii> piii;
typedef pair<double, double> pdd;
typedef pair<string, pii> psi;
typedef __int128 int128;
#define PI acos(-1.0)
#define x first
#define y second
//int dx[4] = {1, -1, 0, 0};
//int dy[4] = {0, 0, 1, -1};
const int inf = 0x3f3f3f3f, mod = 1e9 + 7;
const int N = 55;
int n, q;
set<int> st[N];
int main(){
ios::sync_with_stdio(false);
cin.tie(0); cout.tie(0);
cin >> n;
for(int i = 1; i <= n; i ++ ) {
int k; cin >> k;
while(k -- ){
int x; cin >> x;
st[i].insert(x);
}
}
cin >> q;
while(q -- ){
int a, b; cin >> a >> b;
set<int> v;
//求交集
set_intersection(st[a].begin(), st[a].end(), st[b].begin(), st[b].end(), inserter(v, v.begin()));
//nc即为交集集合的大小 nt即为两个集合大小之和 - nc
int nc = (int)v.size(), nt = (int)st[a].size() + (int)st[b].size() - nc;
double res = nc * 1.0 / nt * 100;
printf("%.2lf%\n", res);
}
return 0;
}
一切都是命运石之门的选择,本文章来源于博客园,作者:MarisaMagic,出处:https://www.cnblogs.com/MarisaMagic/p/17324583.html,未经允许严禁转载