KMP初级

                           Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16335    Accepted Submission(s): 7198


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

 

Sample Output
6
-1
KMP的初级算法, 较简单理解吧
#include<stdio.h>
#include<string.h>

const int MAXN = 1e6+7;

int mumStr[MAXN], sonStr[MAXN];
int Next[MAXN];

void GetNext(int s[], int N, int next[])
{
    int i=0, j=-1;
    next[0] = -1;

    while(i < N)
    {
        if(j==-1 || s[i]==s[j])
            next[++i] = ++j;
        else
            j = next[j];
    }
}
int KMP(int mumStr[], int sonStr[], int Mn, int Sn)
{
    int i=0, j=0;

    GetNext(sonStr, Sn, Next);

    while(i < Mn)
    {
        while(j==-1 || (mumStr[i]==sonStr[j]&&i<Mn&&j<Sn) )
            i++, j++;
        if(j == Sn)
            return i-Sn+1;
        j = Next[j];
    }

    return -1;
}

int main()
{
    int T;

    scanf("%d", &T);

    while(T--)
    {
        int i, Mn, Sn;

        scanf("%d%d", &Mn, &Sn);

        for(i=0; i<Mn; i++)
            scanf("%d", &mumStr[i]);
        for(i=0; i<Sn; i++)
            scanf("%d", &sonStr[i]);

        printf("%d\n", KMP(mumStr, sonStr, Mn, Sn));
    }

    return 0;
}

 

posted on 2015-10-14 23:25  林海梦月  阅读(113)  评论(0编辑  收藏  举报