BZOJ 2763 飞行线路

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0 <= s, t < n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0 <= a, b < n,a与b不相等,0<=c<=1000)

Output

只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1

0 4

0 1 5

1 2 5

2 3 5

3 4 5

2 3 3

0 2 100

Sample Output

8

HINT

对于30%的数据,2<=n<=50,1<=m<=300,k=0;

对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;

对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.

我是大蒟蒻,学长讲了之后才会做的, 外加抄了点代码,然后这道题就A了……

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int MAXN = 100000, MAXE = 21474836;
struct Edge
{
    int from, to, cost;
}es[MAXN << 2];
int first[MAXN], nxt[MAXN], tot, d[MAXN][15], n, m, k;
bool used[MAXN][15];
queue < int > q; 

void build(int f, int t, int d)
{
    es[++tot].from = f;
    es[tot].to = t;
    es[tot].cost = d;
    nxt[tot] = first[f];
    first[f] = tot;
}

void spfa(int s)
{
    d[s][0] = 0;
    q.push(s);
    q.push(0);
    used[s][0] = 1;
    while(!q.empty())
    {
        int x = q.front();
        q.pop();
        int time = q.front();
        q.pop();
        used[x][time] = 0;
        for(int i = first[x]; i != -1; i = nxt[i])
        {
            int u = es[i].to;
            if(d[u][time] > d[x][time] + es[i].cost)
            {
                d[u][time] = d[x][time] + es[i].cost;
                if(!used[u][time])
                {
                    q.push(u);
                    q.push(time);
                    used[u][time] = 1;
                }
            }
            if(time < k)
            {
                if(d[u][time + 1] > d[x][time])
                {
                    d[u][time + 1] = d[x][time];
                    if(!used[u][time + 1])
                    {
                        q.push(u);
                        q.push((time + 1));
                        used[u][time + 1] = 1;
                    }                   
                }
            }
        }
    }
}

int main()
{
    scanf("%d%d%d", &n, &m, &k);
    memset(first, -1, sizeof(first));
    int s, e;
    scanf("%d%d", &s, &e);
    for(int i = 1; i <= m; i++)
    {
        int a, b, c;
        scanf("%d%d%d", &a, &b, &c);
        build(a, b, c);
        build(b, a, c);
    }
    for(int i = 0; i < n; i++)
        for(int  j = 0; j <= k; j++)
            d[i][j] = MAXE;
    spfa(s);
    cout<<d[e][k];
    return 0;
}
posted @ 2016-03-24 21:22  Loi_Vampire  阅读(119)  评论(0编辑  收藏  举报