POJ 2785 4 Values whose Sum is 0 折半枚举

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
-26 -38 -10 62
-32 -54 -6 45

Sample Output
5

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目大意:给定各有n个整数的四个数列A、B、C、D。要从每个数列中各取出1个数,使四个数的和为0。求出这样的组合的个数。当一个数列中有多个相同的数字时,把它们作为不同的数字看待。

!限制条件:
1≤n≤4000
|(数字的值)|≤2^28

从4个数列中选择的话总共有n4种情况,所以全部判断一遍不可行。不过将它们对半分为AB和CD再考虑,就可以快速解决了。从2个数列中选择的话只有n2种组合,所以可以进行枚举。先从A、B中取出a、b后,为了使总和为0则需要从C、D中取出c+d=-a-b。因此先将C、D中取数字的n2种方法全都枚举出来,先将这些和排好序,这样就可以与运用二分搜索了。这个算法的复杂度是O(n2logn)。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAXN = 5000;
int n, A[MAXN], B[MAXN], C[MAXN], D[MAXN], CD[MAXN * MAXN];

void solve()
{
    for(int i = 0; i < n; i++)
        for(int j = 0; j < n; j++)
        {
            CD[i * n + j] = C[i] + D[j];
        }
    sort(CD, CD + n * n);
    LL res = 0;
    for(int i = 0; i < n; i++)
        for(int j = 0; j < n; j++)
        {
            int cd = -(A[i] + B[j]);
            res += upper_bound(CD, CD + (n * n), cd) - lower_bound(CD, CD + (n * n), cd);
        }
    printf("%lld", res);
}

int main()
{
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        scanf("%d%d%d%d", &A[i], &B[i], &C[i], &D[i]);
    solve();
    return 0;
}
posted @ 2016-03-26 14:32  Loi_Vampire  阅读(391)  评论(0编辑  收藏  举报