POJ 3461 Oulipo KMP
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANSample Output
1
3
0Source
BAPC 2006 Qualification
题目大意是这样的:
跟你多组数据, 每组数据中包含两个字符串W和T,询问W在T中出现了多少次。
显然要用KMP
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int SZ = 10010;
const int LA = 1000010;
int nxt[SZ];
void getnxt(char n[])
{
nxt[0] = nxt[1] = 0;
int len = strlen(n);
for(int i = 1; i < len; i ++)
{
int j = nxt[i];
while(j && n[i] != n[j]) j = nxt[j];
nxt[i + 1] = (n[i] == n[j] ? j + 1 : 0);
}
}
int kmp(char n[], char m[])
{
int ans = 0;
int len1 = strlen(n), len2 = strlen(m);
for(int i = 0, j = 0; i < len2; i ++)
{
while(j && n[j] != m[i]) j = nxt[j];
if(n[j] == m[i]) j ++;
if(j == len1) ans ++;
}
return ans;
}
int main()
{
int t;
scanf("%d", &t);
while(t --)
{
memset(nxt, 0, sizeof(nxt));
char n[SZ], m[LA];
scanf("%s", n);
scanf("%s", m);
getnxt(n);
printf("%d\n", kmp(n, m));
}
}