POJ 2104 K-th Number 主席树

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in
sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5 6 3

Hint

This problem has huge input,so please use c-style
input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

主席树存个模板,跪膜神犇DQS和a %%%
感谢来自DQS的模板和来自a的讲解

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long LL;
const int SZ = 5000010;

struct SGT
{
    int l, r, cnt;
}tree[SZ];
int lsh[SZ], Tcnt = 0, rt[SZ], num[SZ];

void insert(int l, int r, int x, int &y, int value)
{
    y = ++Tcnt;
    tree[y] = tree[x];
    tree[y].cnt++;
    if(l == r) return;
    int mid = (l + r) >> 1;
    if(value <= mid) insert(l, mid, tree[x].l, tree[y].l, value);
    else insert(mid + 1, r, tree[x].r, tree[y].r, value);
}

int ask(int l, int r, int x, int y, int k)
{
    if(l == r) return l;
    int mid = (l + r) >> 1;
    if(tree[tree[y].l].cnt - tree[tree[x].l].cnt >= k)
        return ask(l, mid, tree[x].l, tree[y].l, k);
    else return ask(mid + 1, r, tree[x].r, tree[y].r, k - (tree[tree[y].l].cnt - tree[tree[x].l].cnt)); 
}

int main()
{
    int n, m;
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; i++)
    {
        scanf("%d", &num[i]);
        lsh[++lsh[0]] = num[i];
    }
    sort(lsh + 1, lsh + 1 + lsh[0]);
    int len = unique(lsh + 1, lsh + 1 + lsh[0]) - lsh - 1;
    for(int i = 1; i <= n; i++)
    {
        num[i] = lower_bound(lsh + 1, lsh + 1 + len, num[i]) - lsh;
        insert(1, len, rt[i - 1], rt[i], num[i]);
    }
    int l, r, k;
    while(m--)
    {
        scanf("%d%d%d", &l, &r, &k);
        printf("%d\n", lsh[ask(1, len, rt[l - 1], rt[r], k)]);
    }
    return 0;
}
posted @ 2016-09-13 21:40  Loi_Vampire  阅读(74)  评论(0编辑  收藏  举报