HDU1398:Square Coins(DP水题)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15764    Accepted Submission(s): 10843


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

 

Sample Input
2 10 30 0
 

 

Sample Output
1 4 27
 

 

Source
 

 

 
该题目与HDU1284基本相同,仅硬币面额和数量不同
题意:
一个城市的货币有17种,面额为17个平方数,即从1,4,9到289为止。计算用该货币支付一定金额的方法有几种。
题解:
完全背包问题,无脑DP即可。具体见下代码
#define _CRT_SECURE_NO_DepRECATE
#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <iostream>
#include <cmath>
#include <iomanip>
#include <string>
#include <algorithm>
#include <bitset>
#include <cstdlib>
#include <cctype>
#include <iterator>
#include <vector>
#include <cstring>
#include <cassert>
#include <map>
#include <queue>
#include <set>
#include <stack>
#define ll long long
#define INF 0x3f3f3f3f
#define ld long double
const ld pi = acos(-1.0L), eps = 1e-8;
int qx[4] = { 0,0,1,-1 }, qy[4] = { 1,-1,0,0 }, qxx[2] = { 1,-1 }, qyy[2] = { 1,-1 };
using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n, num[20], dp[350] = { 0 };
    for (int i = 1; i <= 17; i++)//先打表
    {
        num[i] = i * i;
    }
    dp[0] = 1;
    for (int i = 1; i <= 17; i++)//依次计算17种面值的货币的情况
    {
        for (int f = 1; f <= 300; f++)
        {
            if (f - num[i] < 0)
            {
                continue;
            }
            dp[f] += dp[f - num[i]];//意即f-num[i]的情况下再加一张num[i]即为f
        }
    }
    while (cin >> n && n)
    {
        cout << dp[n] << endl;
    }
    return 0;
}

 

 
posted @ 2020-04-07 19:41  绝军师  阅读(215)  评论(0编辑  收藏  举报