2019第七周作业
这次作业属于哪个课程 | C语言程序设计 |
---|---|
这次作业要求在哪里 | 第七周作业 |
我在这个课程的目标是 | 学习指针 |
这个作业具体在那个方面帮助我实现目标 | 这次作业使我明白了指针在调用函数中的用法 |
参考文献 | 无 |
第七周基础作业1
每个单词的最后一个字母改成大写
函数fun的功能是:将p所指字符串中每个单词的最后一个字母改成大写。(这里的“单词”是指由空格隔开的字符串)。
函数接口定义:
void fun( char *p );
其中 p 是用户传入的参数。函数将 p所指字符串中每个单词的最后一个字母改成大写。
裁判测试程序样例:
#include <stdio.h>
void fun( char *p );
int main()
{
char chrstr[64]; int d ;
gets(chrstr);
d=strlen(chrstr) ;
chrstr[d] = ' ' ;
chrstr[d+1] = 0 ;
fun(chrstr);
printf("\nAfter changing: %s\n", chrstr);
return 0;
}
/* 请在这里填写答案 */
输入样例:
my friend is happy
输出样例:
After changing: mY frienD iS happY
实验代码
void fun( char *p )
{
int i;
for(i=0;*(p+i)!='\0';i++){
if(*(p+i+1)==' ')
*(p+i)=*(p+i)-'a'+'A';}
}
本次实验中遇到的问题
调用字符串函数需在表头调用#include<string.h>
PTA运行结果截图
流程框图
第七周基础作业2
自动售货机
如图所示的简易自动售货机,物品架1、2上共有10样商品,按顺序进行编号分别为1-10,标有价格与名称,一个编号对应一个可操作按钮,供选择商品使用。如果物架上的商品被用户买走,储物柜中会自动取出商品送到物架上,保证物品架上一定会有商品。用户可以一次投入较多钱币,并可以选择多样商品,售货机可以一次性将商品输出并找零钱。
用户购买商品的操作方法是:
(1)从“钱币入口”放入钱币,依次放入多个硬币或纸币。钱币可支持1元(纸币、硬币)、2元(纸币)、5元(纸币)、10元(纸币),放入钱币时,控制器会先对钱币进行检验识别出币值,并统计币值总额,显示在控制器显示屏中,提示用户确认钱币放入完毕;
(2)用户确认钱币放入完毕,便可选择商品,只要用手指按对应商品外面的编号按钮即可。每选中一样商品,售货机控制器会判断钱币是否足够购买,如果钱币足够,自动根据编号将物品进行计数和计算所需钱币值,并提示余额。如果钱币不足,控制器则提示“Insufficient money”。用户可以取消购买,将会把所有放入钱币退回给用户。
输入格式:
先输入钱币值序列,以-1作为结束,再依次输入多个购买商品编号,以-1结束。
输出格式:
输出钱币总额与找回零钱,以及所购买商品名称及数量。
输入样例:
1 1 2 2 5 5 10 10 -1
1 2 3 5 1 6 9 10 -1
输出样例:
Total:36yuan,change:19yuan
Table-water:2;Table-water:1;Table-water:1;Milk:1;Beer:1;Oolong-Tea:1;Green-Tea:1;
实验代码
#include<stdio.h>
int main (void)
{
int total,i=0,money_sum=0,goods;
int Table_water1=0,Table_water2=0,Table_water3=0,Coca_Cola=0,Milk=0,Beer=0,Orange_juice=0,Sprite=0,Oolong_tea=0,Green_tea=0;
scanf("%d",&total);
while(total!=-1){
money_sum=money_sum+total;
i++;
scanf("%d",&total);
}
total=money_sum;
scanf("%d",&goods);
while(goods!=-1){
if(goods==1){
if(money_sum>=1){
Table_water1++;
money_sum=money_sum-1;
}
else{
i=1;
break;
}
}
else if(goods==2){
if(money_sum>=1){
Table_water2++;
money_sum=money_sum-1;
}
else{
i=1;
break;
}
}
else if(goods==3){
if(money_sum>=1){
Table_water3++;
money_sum=money_sum-1;
}
else{
i=1;
break;
}
}
else if(goods==4){
if(money_sum>=2){
Coca_Cola++;
money_sum=money_sum-2;
}
else{
i=1;
break;
}
}
else if(goods==5){
if(money_sum>=2){
Milk++;
money_sum=money_sum-2;
}
else{
i=1;
break;
}
}
else if(goods==6){
if(money_sum>=3){
Beer++;
money_sum=money_sum-3;
}
else{
i=1;
break;
}
}
else if(goods==7){
if(money_sum>=3){
Orange_juice++;
money_sum=money_sum-3;
}
else{
i=1;
break;
}
}
else if(goods==8){
if(money_sum>=3){
Sprite++;
money_sum=money_sum-3;
}
else{
i=1;
break;
}
}
else if(goods==9){
if(money_sum>=4){
Oolong_tea++;
money_sum=money_sum-4;
}
else{
i=1;
break;
}
}
else if(goods==10){
if(money_sum>=4){
Green_tea++;
money_sum=money_sum-4;
}
else{
i=1;
break;
}
}
scanf("%d",&goods);
}
if(i!=1){
printf("Total:%dyuan,change:%dyuan\n",total,money_sum);
if(Table_water1>0)
printf("Table-water:%d;",Table_water1);
if(Table_water2>0)
printf("Table-water:%d;",Table_water2);
if(Table_water3>0)
printf("Table-water:%d;",Table_water3);
if(Coca_Cola>0)
printf("Coca-Cola:%d;",Coca_Cola);
if(Milk>0)
printf("Milk:%d;",Milk);
if(Beer>0)
printf("Beer:%d;",Beer);
if(Orange_juice>0)
printf("Orange-juice:%d;",Orange_juice);
if(Sprite>0)
printf("Sprite:%d;",Sprite);
if(Oolong_tea>0)
printf("Oolong-Tea:%d;",Oolong_tea);
if(Green_tea>0)
printf("Green-Tea:%d;",Green_tea);
}
else
printf("Insufficient money");
return 0;
}
PTA运行结果截图
第七周预习作业
使用函数删除字符串中的字符
输入一个正整数 repeat (0<repeat<10),做 repeat 次下列运算:
输入一个字符串 str,再输入一个字符 c,将字符串 str 中出现的所有字符 c 删除。
要求定义并调用函数delchar(str,c), 它的功能是将字符串 str 中出现的所有 c 字符删除,函数形参str的类型是字符指针,形参c的类型是char,函数类型是void。
输入输出示例:括号内为说明,无需输入输出
输入样例:
3 (repeat=3)
happy new year (字符串"happy new year")
a (待删除的字符'a')
bee (字符串"bee")
e (待删除的字符'e')
111211 (字符串"111211")
1 (待删除的字符'1')
输出样例:
result: hppy new yer (字符串"happy new year"中的字符'a'都被删除)
result: b (字符串"bee"中的字符'e'都被删除)
result: 2 (字符串"111211"中的字符'1'都被删除)
实验代码
#include<stdio.h>
void delchar (char *s,char c);
int main (void)
{
char a[100];
char c,b,d,e;
int i,repeat;
scanf("%d",&repeat);
scanf("%c",&d);
for(i=1;i<=repeat;i++){
gets(a);
scanf("%c",&b);
scanf("%c",&e);
printf("result: ");
delchar(a,b);
}
return 0;
}
void delchar (char *s,char b)
{
int d,i=0;
for(;*s!='\0';s++){
if(*s!=b)
putchar(*s);
}
printf("\n");
}
PTA运行结果截图
流程框图
学习进度条
周/日 | 这周所花时间 | 代码行 | 学到的知识点 |
---|---|---|---|
4/7-4/13 | 十一小时 | 550行 | 指针在调用函数中运用 |