【poj2155】【Matrix】二位树状数组

这里写图片描述
[pixiv] https://www.pixiv.net/member_illust.php?mode=medium&illust_id=34310873

Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
题目大意
给一个N*N的矩阵,里面的值不是0,就是1。初始时每一个格子的值为0。
现对该矩阵有两种操作:(共T次)
1.C x1 y1 x2 y2:将左上角为(x1, y1),右下角为(x2, y2)这个范围的子矩阵里的值全部取反。
2.Q x y:查询矩阵中第i行,第j列的值。

根据数据范围,横纵两个方向都必须是log级的复杂度。如果按照题目原意直接模拟,区间修改单点查询,需要用线段树。但是我并不会二位线段树。那么就利用差分的思想,使其转化为单点修改区间查询,可以用树状数组来维护。

一维的差分是这样的
[le,ri]+val
这里写图片描述
那么二维的就是
这里写图片描述
但是详细的,(x,y)+1,是指的从(x,y)到(n,n)的矩阵都+1
那么根据容斥原理
这里写图片描述
由此一来,单点查询时就查询(0,0)到(x,y)的和

现在就是二维树状数组怎么实现的问题了
其实很简单,就是两个for套在一起就是了

void modify(int x,int y,int val){
    for(int i=x;i<=n;i+=(i&(-i)))
        for(int j=y;j<=n;j+=(j&(-j)))
            c[i][j]++;
}

完整代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N=1000+5;
const int T=50000+5;

int n,t;
int c[N][N];

void modify(int x,int y,int val){
    for(int i=x;i<=n;i+=(i&(-i)))
        for(int j=y;j<=n;j+=(j&(-j)))
            c[i][j]++;
}
int query(int x,int y){
    int rt=0;
    for(int i=x;i>0;i-=(i&(-i)))
        for(int j=y;j>0;j-=(j&(-j)))
            rt+=c[i][j];
    return rt;
}
void solve(){
    scanf("%d%d",&n,&t);
    memset(c,0,sizeof(c));
    while(t--){
        char opt[2];
        scanf("%s",opt);
        if(opt[0]=='C'){
            int x1,y1,x2,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            modify(x1,y1,1);
            modify(x1,y2+1,-1);
            modify(x2+1,y1,-1);
            modify(x2+1,y2+1,1);
        }
        else{
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",query(x,y)%2);
        }       
    }
    printf("\n");
}
int main(){
    int x;
    scanf("%d",&x);
    while(x--) solve();
    return 0;
}

总结:
1、看到操作不必直接模拟,用差分等思想可以化难为简

posted @ 2017-10-31 19:09  LinnBlanc  阅读(180)  评论(0编辑  收藏  举报