HDU 3449 Consume 依賴背包DP

Time limit  2000 ms

Memory limit  65536 kB

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money. 

InputThe first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000) 
OutputFor each test case, output the maximum value FJ can get 
Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output

210

本題大意:
  給出n個盒子,m元錢,去購物,特定的盒子才能裝特定的貨物,所以要買特定貨物之前必須先買對應的盒子。題意簡單明了,是一個依賴背包問題

解題思路:
  我也是初學DP,是借鑒了一些大神的AC代碼才做出來的,看懂之後實際上這題也挺簡單,但畢竟是新學的東西,寫個博記錄一下。學會01背包后,看下面代碼就可以理解。
#include<bits/stdc++.h>
#define N 60
#define M 100009
using namespace std;
int dp[N][M];//第一維是盒子,第二維是價值(注意不是價錢,本題有價錢和價值)
int n,W;
int main()
{
    //freopen("a.txt","r",stdin);
    while(~scanf("%d%d",&n,&W))
    {
        memset(dp,-1,sizeof(dp));//依賴性,給-1作為標記
        memset(dp[0],0,sizeof(dp[0]));//

        for(int i=1;i<=n;i++)
        {
            int c,num;
            scanf("%d%d",&c,&num);//c是盒子價錢

            for(int j=c;j<=W;j++)
                dp[i][j]=dp[i-1][j-c];//先買盒子

            for(int j=1;j<=num;j++)
            {
                int v,w;
                scanf("%d%d",&v,&w);
                for(int k=W;k>=v;k--)
                {
                    if(dp[i][k-v]!=-1)//如果k-v等於-1說明k-v小於盒子價格
                        dp[i][k]=max(dp[i][k],dp[i][k-v]+w);//購買DP
                }

            }
            for(int j=0;j<=W;j++)
                dp[i][j]=max(dp[i-1][j],dp[i][j]);//同時還要判斷這個盒子要不要
        }
        printf("%d\n",dp[n][W]);
    }
}

 

 
posted @ 2018-08-22 17:11  Lin88  阅读(123)  评论(0编辑  收藏  举报