Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
代码:

#include<iostream>
using namespace std;
int main()
{
  int a;
  cin>>a;
  while(!cin.eof())
  {
    if(a%2!=0)         //注意特殊情况
      cout<<(a+1)/2*a<<endl<<endl;    
    else
      cout<<a/2*(a+1)<<endl<<endl;
    cin>>a;
  }
}