L1-062 幸运彩票 (15 分)

L1-062 幸运彩票 (15 分)

彩票的号码有 \(6\) 位数字,若一张彩票的前 \(3\) 位上的数之和等于后 \(3\) 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。

输入格式:

输入在第一行中给出一个正整数 \(N \; (\leq 100)\)。随后 \(N\) 行,每行给出一张彩票的 \(6\) 位数字。

输出格式:

对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.

输入样例:

2
233008
123456

输出样例:

You are lucky!
Wish you good luck.

代码:

#include<bits/stdc++.h>
using namespace std;
int n;
string s;
int main()
{
    cin>>n;
    while(n--)
    {
        cin>>s;
        if(s[0]+s[1]+s[2]==s[3]+s[4]+s[5])
            cout<<"You are lucky!"<<endl;
        else cout<<"Wish you good luck."<<endl;
    }
    return 0;
}
posted @ 2021-04-22 02:21  冷蕴  阅读(178)  评论(0编辑  收藏  举报