HDOJ 1008 Elevator 解题报告

下午回来写HDOJ 1008,

一看题目觉得真的很简单,,

写着写着,,

写完了突然发现AC不了,,

调试之后发现还是没问题,

但就是AC不了。

无奈之下看了别人写的代码,

原来是自己题目理解错误了,

题目的意思是到了该楼层再停,,

我误以为是每层都停下来,,

所以写错了。。。。

 

 

这题确实是一道水题。。

http://acm.hdu.edu.cn/showproblem.php?pid=1008

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32135    Accepted Submission(s): 17432


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

 

Output
Print the total time on a single line for each test case.
 

 

Sample Input
1 2 3 2 3 1 0
 

 

Sample Output
17 41
 

 

Author
ZHENG, Jianqiang
 

 

Source
 

 

Recommend
JGShining
 
 
 
没什么好说的,真的水题,
按照题目意思来做,
就顺利写出来了。
#include "stdio.h"
int main()
{
 int i,n;
 int t[100],sum;
 while (scanf("%d",&n)!=EOF &&n !=0)
 {
     t[0]=0;
     for(i=1, sum=0 ;i<=n;i++)
         {
             scanf("%d",&t[i]);
             if(t[i-1]<t[i])
             sum+=(t[i]-t[i-1])*6+5;      //上楼
             else 
            sum+=(t[i-1]-t[i])*4+5;      //下楼
              
         }
         printf("%d\n",sum);
 }
 return 0;
}

 

posted @ 2013-04-28 18:51  Geekers  阅读(243)  评论(0编辑  收藏  举报