HDOJ 1455 Sticks

Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3171 Accepted Submission(s): 780


Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original
 length of those sticks. All lengths expressed in units are integers greater than zero.
 


 

Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths
of those parts separated by the space. The last line of the file contains zero.
 


 

Output
The output file contains the smallest possible length of original sticks, one per line.
 


 

Sample Input
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
 


 

Sample Output
6 5

 

 


#include<iostream>
#include<algorithm>
using namespace std;
int len,num,sum,snum;
int stickslenth[100];
int makt[100]; //用于标记木棍是否被使用
int lim;
bool cmp(const int a,const int b)
{
      return a > b;
}
bool dfs(int lastlen,int b)
{
       int i;
      if( -- lim <= 0)
      return false;
     if(lastlen == 0)//一根木棒已经找出
     {
             i = 0;
             while(i < num && makt[i])
             i++;
             if(i == num)             //当全部的木棍都找出来了的时候则返回真
                   return true;
             makt[i] = true;          //将第i个数据标记为已经访问过
            if(dfs(len - stickslenth[i],i + 1))      //搜索下一根木棍
                      return true;
             makt[i] = false;
             return false;
      }
      int perlen = -1;
      for(i = b; i < num ; ++i)
      {
             if(makt[i] || lastlen < stickslenth[i] || perlen == stickslenth[i])
                     continue;
             makt[i] = true;
             if(dfs(lastlen-stickslenth[i],i+1,t+1))
                      return true;

              makt[i] = false;

              perlen = stickslenth[i];

              if(lastlen == stickslenth[i])
              return false;
        }
      return false;
}

//-------------------------------------------------------------------------------------------------------------
int main()
{
        while( cin >> num , num)
         {
                 sum = 0;
                 for(int i = 0; i < num; i++)
                 {
                        cin >> stickslenth[i];
                       sum += stickslenth[i];
                 }
               sort(stickslenth,stickslenth+num,cmp);
              /*
               for(i = 0; i < num ; i++)
              cout << stickslenth[i] <<  " ";
              cout << endl;
            */
               for(len = stickslenth[0]; len < sum; len++)
               {
                     if(sum % len == 0)//当可以平分为     1156gfddfk;lsdfkl;sdfopksdfsdp[fp[lagsdfksdfdsfsdf
                    {
                              snum = sum/len;
                             memset(makt,false,sizeof(makt));
                            if(dfs(len,0,0))
                                  break;
                     }
              }
              cout << len << endl; 
         }
         return 0;
}

posted @ 2012-08-01 20:24  一生挚爱  阅读(120)  评论(0编辑  收藏  举报