1125 Chain the Ropes (25分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2N104​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15
 

Sample Output:

14

思路:贪心,因为越先加进去的被减半的次数会越多,所以让长的绳子尽可能不被对半,先加入短的绳子。


#include<bits/stdc++.h>
using namespace std;
vector<int> ve;
int main(){
    int n;
    cin>>n;
    ve.resize(n);
    for(int i=0; i<n; ++i) cin>>ve[i];
    sort(ve.begin(), ve.end());
    double sum=ve[0];
    for(int i=1; i<n; ++i) sum = (sum+ve[i])/2;
    cout<<floor(sum)<<endl;
    return 0;
}

 

posted @ 2020-07-18 20:45  Unknown_Island  阅读(77)  评论(0编辑  收藏  举报