UVA 133 环形队列

The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

 

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

 

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

 

Sample input

 

10 4 3
0 0 0

 

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

题目链接:http://acm.uva.es/local/online_judge/search_uva.html

题目大意:环形队列问题,有N张牌,k表示从最左开始,往右每次隔k张牌取出一张,到最右边之后再回到最左边;m则是从最右边开始,往左每次隔m张牌取出一张,到最左边之后再回到最右边,直到把牌全部取出

 

#include <iostream>
#include <iomanip>
using namespace std;
int queue[25];
int main()
{
    int n,k,m;
    int front,rear,count1,count2,cc;
    while(cin>>n>>k>>m)
    {
        if(!n&&!k&&!m)//判断输入是否结束
        break;
        for(int i=1; i<=n; i++)//队列数组的初始化
            queue[i]=i;
        front=0;
        rear=n+1;
        cc=0;
        while(cc<n)//控制进度
        {
            count1=0;count2=0;
            while(1)
            {
                if(queue[front]!=0)//读到未抽出的牌并计数
                {
                    count1++;
                }
                if(front>n)//如果从左往右到最右面返回最左边
                    front=0;
                if(count1==k)//按格式输出抽出的牌
                {
                    cout<<setw(3)<<queue[front];
                    cc++;
                    break;
                }
                front++;
            }
            while(1)//同上,只是这是从右往左开始抽牌
            {
                if(queue[rear]!=0)
                {
                count2++;
                }
                if(rear<1)
                    rear=n+1;
                if(count2==m)
                {
                    if(queue[front]!=queue[rear])
                    {
                        cout<<setw(3)<<queue[rear];
                        cc++;
                    }
                    break;
                }
                rear--;
            }
            queue[front]=0;//将牌抽出后标记为0
            queue[rear]=0;//将牌抽出后标记为0
            if(cc!=n)
            cout<<",";
        }
        cout<<endl;
    }
    return 0;
}
View Code

 

 

 

posted on 2013-07-17 11:34  Forgiving  阅读(114)  评论(0编辑  收藏  举报