HDU 1170

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16637    Accepted Submission(s): 6073

Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem. Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. Is it very easy? Come on, guy! PLMM will send you a beautiful Balloon right now! Good Luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 
Sample Input
4 + 1 2 - 1 2 * 1 2 / 1 2
 
Sample Output
3 -1 2 0.50
需要注意的是当‘/’的时候,只有当a%b!=0的时候输出小数
#include<iostream>
using namespace std;
int main()
{
 int n,a,b;
 char f;
 cin>>n;
 while(n--)
 {
  cin>>f>>a>>b;
  if(f=='+')
   cout<<a+b;
  else if(f=='-')
   cout<<a-b;
  else if(f=='*')
   cout<<a*b;
  else         //注意当a%b!=0时才输出小数
  {
   if(a%b!=0)
    printf("%.2f",a/(b*1.0));
   else
    cout<<a/b;
  }
   cout<<endl;
 }
 return 0;
}
View Code

 

posted on 2013-07-16 03:00  Forgiving  阅读(162)  评论(0编辑  收藏  举报