HDU 3047 并查集

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 859    Accepted Submission(s): 347

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern  stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered  1--300, counted clockwise, we assume the number of rows were infinite. These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there  numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means  people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B  must in column 6th (6=4+2). Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has  conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the  incorrect requests and count them as R.
 
Input
There are many test cases: For every case: The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space. Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.
 
Output
For every case: Output R, represents the number of incorrect request.
 
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
 
Sample Output
2
PS: the 5th and 10th requests are incorrect
1.弄清题意,找出出现冲突的位置,判断冲突很简单就是当两个人在同一行坐,同时他们到根节点的距离差值正好是他们之间的差值,此时就出现了冲突了。
2.关键有两个地方,这也是并查集题目的难点,就是压缩集合,和求节点到根的距离。这里压缩集合就很简单了,一个通用的递归。求到跟的距离dist[a] += dist[tem]; dist[rb]=dist[a]+x-dist[b];注意这两行代码,这是核心代码,首先第一行是求出节点a到根的距离,第二行代码是根据数学中的向量得出的
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXNUM 50005

using namespace std;
//father:存储的是结点的结点的下标,dist存储的是相对于父结点的距离
int father[MAXNUM],dist[MAXNUM];
int n,m;

int find_father(int a)
{
    if(father[a]==a)return a;
    int tem = father[a];
    father[a]=find_father(father[a]);
    dist[a] += dist[tem];
    return father[a];
}

void union_set(int a,int b,int x)
{
    int ra = find_father(a);
    int rb = find_father(b);
    father[rb]=ra;
    dist[rb]=dist[a]+x-dist[b];
}
int main()
{
    int a,b,ra,rb,x,conflics;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dist,0,sizeof(dist));
        for(int i=0;i<=n;i++)
        father[i]=i;
        conflics=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&x);
            ra = find_father(a);
            rb = find_father(b);
            if(ra==rb)
            {
                if(dist[b]-dist[a]!=x)conflics++;
            }
            if(ra!=rb)union_set(a,b,x);
        }
        printf("%d\n",conflics);
    }
    return 0;
}
View Code

 

posted on 2013-07-14 02:29  Forgiving  阅读(121)  评论(0编辑  收藏  举报