HDU 2734 字符串处理

Quicksum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 447 Accepted Submission(s): 339
 
Problem Description
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.
For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.
A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":
ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
 
Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
 
Output
For each packet, output its Quicksum on a separate line in the output.
 
Sample Input
ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#
 
Sample Output
46
650
4690
49
75
14
15

 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2734

题目大意就是让你计算所有字母所在位置的和,就是根据公式计算就行了,没什么弯弯

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

根据上面的例子很容易就得到通式:sum+=(字母位置+1)*字母在字母表里的排名

我在这里写了两个AC代码,一个是if else 一个是switch语句,整体来看,if else会更简洁点,所有在不同的情况下选择不同的表达方式

switch语句:

#include <iostream>
#include <string>
using namespace std;
int main()
{
    char a[2013];
    int l;
    while(1)
    {
        gets(a);
        if(a[0]=='#')
            break;
        l=strlen(a);
        int i;
        int sum=0;
        for(i=0;i<l;i++)
        switch(a[i])
        {
        case 'A':sum=sum+(i+1)*1;break;
        case 'B':sum=sum+(i+1)*2;break;
        case 'C':sum=sum+(i+1)*3;break;
        case 'D':sum=sum+(i+1)*4;break;
        case 'E':sum=sum+(i+1)*5;break;
        case 'F':sum=sum+(i+1)*6;break;
        case 'G':sum=sum+(i+1)*7;break;
        case 'H':sum=sum+(i+1)*8;break;
        case 'I':sum=sum+(i+1)*9;break;
        case 'J':sum=sum+(i+1)*10;break;
        case 'K':sum=sum+(i+1)*11;break;
        case 'L':sum=sum+(i+1)*12;break;
        case 'M':sum=sum+(i+1)*13;break;
        case 'N':sum=sum+(i+1)*14;break;
        case 'O':sum=sum+(i+1)*15;break;
        case 'P':sum=sum+(i+1)*16;break;
        case 'Q':sum=sum+(i+1)*17;break;
        case 'R':sum=sum+(i+1)*18;break;
        case 'S':sum=sum+(i+1)*19;break;
        case 'T':sum=sum+(i+1)*20;break;
        case 'U':sum=sum+(i+1)*21;break;
        case 'V':sum=sum+(i+1)*22;break;
        case 'W':sum=sum+(i+1)*23;break;
        case 'X':sum=sum+(i+1)*24;break;
        case 'Y':sum=sum+(i+1)*25;break;
        case 'Z':sum=sum+(i+1)*26;break;
        case ' ':sum=sum;break;
        default:break;
        }
        cout<<sum<<endl;
        sum=0;
    }
    return 0;
}
View Code

if else语句:

#include <iostream>
#include <string.h>
#include <ctype.h>
using namespace std;

int main()
{
    char a[255];
    int sum;
    while(gets(a)&&a[0]!='#')
    {
        sum=0 ;
        for(int j=0;j<strlen(a);j++)
        {
            if(a[j]!=' ')
            sum+=(((int)a[j]-64)*(j+1));
        }
        cout<<sum<<endl;
    }
    return 0;
}
View Code

 

posted on 2013-07-14 01:16  Forgiving  阅读(421)  评论(0编辑  收藏  举报