HDU 2629 字符串处理

Identity Card

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 995 Accepted Submission(s): 310
 
Problem Description
Do you own an ID card?You must have a identity card number in your family's Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it. Here is the codes which represent the region you are in. However,in your card,maybe only 33 appears,0000 is replaced by other numbers. Here is Samuel's ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
 
Input
Input will contain 2 parts: A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
 
Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
 
Sample Input
1
330000198910120036
 
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2629

 看懂题目,是中国人,有身份证就能做的出来,就是读生日位置和省份位置就行了,其他的不问,我这里用了if else 和switch语句两种方法做的,虽然if else字节比较多但是都是复制粘贴整体写起来比switch要快那么一点下面是两个AC代码

if else版

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    char a[18];
    memset(a,0,sizeof(a));
    while(n--)
    {
        cin>>a;
        if(a[0]=='3' && a[1]=='3')
            cout<<"He/She is from Zhejiang,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='1' && a[1]=='1')
            cout<<"He/She is from Beijing,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='7' && a[1]=='1')
            cout<<"He/She is from Taiwan,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='8' && a[1]=='1')
            cout<<"He/She is from Hong Kong,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='8' && a[1]=='2')
            cout<<"He/She is from Macao,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='5' && a[1]=='4')
            cout<<"He/She is from Tibet,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='2' && a[1]=='1')
            cout<<"He/She is from Liaoning,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        if(a[0]=='3' && a[1]=='1')
            cout<<"He/She is from Shanghai,and his/her birthday is on "
            <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<
            a[9]<<" "<<"based on the table.";
        cout<<endl;
    }
    return 0;
}
View Code

switch版

#include <iostream>
#include <string>
using namespace std;
int main()
{
    int n,t;
    string home,a;
    cin>>n;
    for(int k = 0 ; k < n ; k++)
    {
        cin>>a;
        t = (a[0]-'0')*10+a[1]-'0';
        switch(t)
        {
            case 11:home = "Beijing";break;
            case 31:home = "Shanghai";break;
            case 21:home = "Liaoning";break;
            case 33:home = "Zhejiang";break;
            case 54:home = "Tibet";break;
            case 71:home = "Taiwan";break;
            case 81:home = "Hong Kong";break;
            case 82:home = "Macao";break;
            default :break;
        }
        cout<<"He/She is from "<<home<<",and his/her birthday is on "
        <<a[10]<<a[11]<<","<<a[12]<<a[13]<<","<<a[6]<<a[7]<<a[8]<<a[9]
        <<" based on the table."<<endl;
    }
    return 0;
}
View Code

 

posted on 2013-07-14 00:45  Forgiving  阅读(166)  评论(0编辑  收藏  举报