Function Run Fun-hdu1331-递归+记忆化搜索

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

InputThe input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result. 
OutputPrint the value for w(a,b,c) for each triple.Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1 

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
题意:给出三个参数,求出函数值
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int dp[25][25][25];
int w(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
        return 1;
    if(a>20||b>20||c>20)
        return w(20,20,20);
    if(dp[a][b][c])//这段代码必须在上述对a、b、c处理之后,放置在这个位置,不然会WA
        return dp[a][b][c];
    if(a<b&&b<c)
        dp[a][b][c]= w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c);
    else
        dp[a][b][c]=w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1);
    return dp[a][b][c];
}
int main()
{
    int a,b,c;
    memset(dp,0,sizeof(dp));
    while(~scanf("%d%d%d",&a,&b,&c)){
        if(a==-1&&b==-1&&c==-1)break;
        printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
    }
    return 0;
}
posted @ 2019-07-19 16:39  里昂静  阅读(245)  评论(0编辑  收藏  举报