Balanced Lineup-利用线段树求区间最大值与最小值之差

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:给出N,Q,在一个含有N个数的序列中,询问Q次[a, b]中的最大值最小值差值
利用线段树来分别维护区间[a,b]内的最大值和最小值,最后由二者相减即可得出结果。
#include<cstdio>
#include<iostream>
using namespace std;
const int maxn=200005;
int a[maxn],ma[4*maxn],mi[4*maxn];

void build(int q,int l,int r)
{
    if(l==r){
        ma[q]=a[l];
        mi[q]=a[l];
        return;
    }
    int mid=(l+r)/2;
    build(q*2,l,mid);
    build(q*2+1,mid+1,r);
    ma[q]=max(ma[q*2],ma[q*2+1]);//向下更新区间的最大值,值为max(左区间最大值,右区间最大值)
    mi[q]=min(mi[q*2],mi[q*2+1]);
}

int queryma(int q,int l,int r,int L,int R)//查找区间[L,R]内的最大值
{
    if(l>=L&&r<=R){
        return ma[q];
    }
    int mid=(l+r)/2,res=0;
    if(L<=mid)
        res=max(queryma(q*2,l,mid,L,R),res);//找出左子区间最大值与当前最大值比较
    if(R>mid)
        res=max(queryma(q*2+1,mid+1,r,L,R),res);//找出右子区间最大值与当前最大值比较
    return res;//别忘了返回最终结果
}

int querymi(int q,int l,int r,int L,int R)//查找区间[L,R]内的最小值
{
    if(l>=L&&r<=R){
        return mi[q];
    }
    int mid=(l+r)/2,res=1000005;
    if(L<=mid)
        res=min(querymi(q*2,l,mid,L,R),res);//找出左子区间最大值与当前最大值比较
    if(R>mid)
        res=min(querymi(q*2+1,mid+1,r,L,R),res);//找出右子区间最大值与当前最大值比较
    return res;
}
int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
    }
    build(1,1,n);
    int A,B;
    for(int i=0;i<q;i++){
        scanf("%d%d",&A,&B);
        printf("%d\n",queryma(1,1,n,A,B)-querymi(1,1,n,A,B));
    }
    return 0;
}
posted @ 2019-07-11 20:00  里昂静  阅读(445)  评论(0编辑  收藏  举报