POJ 1014 Dividing

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

 
    题目大致意思:就是有一堆石头,想要根据质量平均分成两份,但是石头不能被切割,问你能不能刚好分成两份。
    分析:
    1.很明显是一个背包问题
    2.背包的容量就是石头质量的一半
    3.如果石头的总质量是奇数,那么不可能平均分成两半
    4.最后求出的背包装下的最大质量等于石头质量的一半,那么就可以分成两半
 
代码如下:
#include <iostream>

using namespace std;

int bag[100];
int num, Size;
int a[100];

int MAX(int a, int b) { return a > b ? a : b; }

void ZeroOnePack(int weight,int value)                  //01背包求解
{
    for (int i = Size; i >= weight; i--)
        bag[i] = MAX(bag[i], bag[i - weight] + value);
}

int main()
{
    int sum;
    int time = 0;
    while (1)
    {
        time++;
        sum = 0;
        memset(bag, 0, sizeof(bag));
        for (int i = 1; i <= 6; i++)
        {
            cin >> a[i];
            sum += a[i]*i;
        }
        if (!sum) break;
        If(sum%2)                                     //石头总质量为奇数不能被平分
        {
            cout << "Collection #" << time << ":" << endl;
            cout<<"Can't be divided." << endl;
            continue;
        }
        Size = sum / 2;
        for (int i = 1; i <= 6; i++)
        {
            if (a[i] == 0) continue;
            for (int j = 0; j < a[i]; j++)
                ZeroOnePack(i, i);                   //石头花费的空间和质量一样
        }
        cout << "Collection #" << time << ":" << endl;
        if (bag[Size] == Size) cout << "Can be divided." << endl;
        else cout << "Can't be divided." << endl;
    }
}

 

posted @ 2017-12-08 09:28  念你成疾  阅读(146)  评论(0编辑  收藏  举报