POJ 1007 DNA Sorting

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

 
    题目大致意思:很水的一道题,就是让你按照序列的大小从大到小重新排序一次就好,序列的大小就是第一个字母后面比它大的所有字母的个数+第二个字母后面比它大的所有字母的个数+......
 
代码如下:
#include<iostream>

using namespace std;

struct N
{
    char a[50];
    int num;
}Line[100];

void quicksort(int left, int right)                                                       //快速排序
{
    int i, j;
    struct N temp;
    if (left < right)
    {
        i = left, j = right, temp = Line[i];
        while (i < j)
        {
            while (Line[j].num <= temp.num&&i < j) j--;
            Line[i] = Line[j];
            while (Line[i].num >= temp.num&&i < j) i++;
            Line[j] = Line[i];
        }
        Line[i] = temp;
        quicksort(left, j - 1);
        quicksort(j + 1, right);
    }
}

int main()
{
    int n, m;
    int count;
    cin >> m >> n;
    for (int i = 0; i < n; i++)
        for (int j = 0; j < m; j++)
            cin >> Line[i].a[j];
    for (int i = 0; i < n; i++)
    {
        count = 0;
        for (int j = 0; j < m; j++)
        {
            char ch = Line[i].a[j];
            for (int k = j; k < m; k++)
                if (Line[i].a[k] >= ch) count++;
        }
        Line[i].num = count;
    }
    quicksort(0, n-1);
    for (int i = 0; i < n; i++)
        cout << Line[i].a << endl;
}

 

posted @ 2017-12-07 21:43  念你成疾  阅读(100)  评论(0编辑  收藏  举报