[ POJ ][ 高斯消元 ] 1222 EXTENDED LIGHTS OUT

EXTENDED LIGHTS OUT
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10354   Accepted: 6667

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

 

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

 

Sample Output

 

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

 

Source

-----------------------------------------------------我是分割线----------------------------------------------------------------------
  建立一个增广矩阵g[1...n][1.....n+1]用来高斯消元。
  可是,
  连方程都没有你解个啥子?
  这时出现了我们的终极杀手:异或方程。
  对于每一个位置(i, j):存在位置(x1,y1)(x2,y2)...对其产生影响。
  所以设对ai有影响的开关位置是xn
  xa^xb^xc^... = map[a1]
  xd^xe^xf^... = map[a2]
  例如对于矩阵:    
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0

  其增广矩阵:

 

1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 0 0 0 1 1 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
1 0 0 0 0 0 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 0 0 0 0 1 0 0 0 0 1 1 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 1 
0 0 0 0 0 0 1 0 0 0 0 0 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 
0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 
0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 1 
0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 
0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 
0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 0 0 0 0 0 1 0 0 0 0 0 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 1 1 0 0 0 0 1 0 0 0 0 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 0 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 0 0 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 0 1 0 0 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 0 0 0 0 0 1 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 1 1 0 0 0 0 0 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 1 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 1 0 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 1 1 0 

增广矩阵的最后一列即为等号右边的数(每一行对应一个map[i],原矩阵逐行展开)

0 1 1 0 1 0      0
1 0 0 1 1 1      1
0 0 1 0 0 1   ->    1
1 0 0 1 0 1      0
0 1 1 1 0 0          1
                    ...

  

如何造出这个矩阵?

  其实等号左边每一列都代表一个方程的元xi,同时也代表原矩阵上的一个位置(逐行展开)对于等号左边的每一列,

  在这一列上把该位置能控制的位置(每一行也是一个位置)标为1,之后进行高斯消元即可。

 

//Kvar_ispw17
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;
const int maxn = 31;
int g[maxn][maxn], ans[maxn], T;
inline void init() {
	memset(g, 0, sizeof g);
	for(int i = 0; i < 5; i++) {
		for(int j = 0; j < 6; j++) {
			int p = i * 6 + j;
			g[p][p] = 1;
			if(i > 0) g[(i - 1) * 6 + j][p] = 1;
			if(i < 4) g[(i + 1) * 6 + j][p] = 1;
			if(j > 0) g[ i * 6  + j - 1][p] = 1;
			if(j < 5) g[ i * 6  + j + 1][p] = 1;
		}
	}
}
inline void gauss() {
	for(int r, k = 0, c = 0; k < 30 && c < 30; k++, c++) {
		r = k;
		for(int i = k + 1; i < 30; i++) {
			if(abs(g[i][c]) > abs(g[r][c])) r = i;
		}
		if(r != k) { 
			for(int j = c; j < 31; j++) swap(g[k][j], g[r][j]);
		}
		if(g[k][c] == 0) { 
			k--; 
			continue;
		}
		for(int i = k + 1; i < 30; i++) {
			if(g[i][c]) {
				for(int j = c; j < 31; j++) g[i][j] ^= g[k][j];
			}
		}
	}
	for(int i = 29; i >= 0; i--) {
		ans[i] = g[i][30];
		for(int j = i + 1; j < 30; j++) {
			ans[i] ^= (g[i][j] && ans[j]);
		}
	}
}
void print() {
	for(int i = 0; i < 30; i++) {
		for(int j = 0; j < 31; j++) cout << g[i][j] << " ";
		cout << endl;
	}
}
int main() {
	freopen("1222.in", "r", stdin);
	freopen("1222.out", "w", stdout);
	scanf("%d", &T);
	for(int t = 1; t <= T; t++) {
		init();
		for(int i = 0; i < 30; i++) scanf("%d", &g[i][30]);
		print();
		gauss();
		printf("PUZZLE #%d", t);
		for(int j = 0; j < 30; j++) {
			if(!(j % 6)) printf("\n%d", ans[j]);
			else printf(" %d", ans[j]);
		}
		printf("\n");
	}
	return 0;
}

 

  

 

 

 

posted @ 2017-04-27 20:38  Kvar_ispw17  阅读(200)  评论(0编辑  收藏  举报