2021-08-26 AcWing 3816. 移动元素
思路:哈希表
输入样例:
3
3
1 3 2
5
1 2 3 4 5
5
2 2 3 4 5
输出样例:
YES
NO
YES
#include <iostream>
#include <cstring>
#include <algorithm>
#include <unordered_map>
using namespace std;
typedef long long LL;
const int N = 1e5+10;
int a[N];
int n;
void check()
{
unordered_map<LL, int>cnt1,cnt2;
LL sum = 0;
for (int i = 0; i < n; i ++ )
{
scanf("%d", &a[i]);
cnt1[a[i]] ++;
sum += a[i];
}
if(sum%2){
cout << "NO" << endl;
return ;
}
LL s=0;
LL half = sum >> 1;
for (int i = 0; i < n; i ++ )
{
s += a[i];
cnt1[a[i]]--;//前半部分已被选中的,对应的value减一;
cnt2[a[i]]++;
if(cnt1[half-s]>0 || cnt2[s-half]>0){
cout << "YES" << endl;
return ;
}
}
cout << "NO" << endl;
}
int main()
{
int t;
cin >> t;
while (t -- )
{
cin >> n;
check();
}
return 0;
}
本文来自博客园,作者:泥烟,CSDN同名, 转载请注明原文链接:https://www.cnblogs.com/Knight02/p/15799122.html