2021-08-29 AcWing第十四场周赛 3822. 食堂排队
模拟
输入样例:
2
2
1 3
1 4
3
1 5
1 1
2 3
输出样例:
1 2
1 0 2
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
int t,n;
cin >> t;
while (t -- )
{
cin >> n;
int l,r,last=0;
while (n -- )
{
cin >> l >> r;
if(max(l,last)>r){
cout << 0 << ' ';
}else{
cout << max(l,last) << ' ';
last = max(l,last)+1;
}
}
cout << endl;
}
return 0;
}
本文来自博客园,作者:泥烟,CSDN同名, 转载请注明原文链接:https://www.cnblogs.com/Knight02/p/15799119.html