[D-OJ练习] 求二叉树的深度
采用先序法建立一棵二叉树,设计求该二叉树的深度,二叉树的数据域类型为字符型,扩展二叉树的叶子结点用‘#’表示,要求可以求多棵二叉树的深度,当二叉树的深度为0时程序结束。
输入描述
循环输入多棵扩展二叉树的先序遍历序列,每棵树占一行,以回车结束,每棵二叉树中结点之间以空格隔开
输出描述
输出各二叉树的深度,每次输出后面都换行
输入样例
A B # # C D # E # F # # G H # I K # # # #
A B D H # # I # # E J # # K # # C F L # # M # # G N # # O # #
#
输出样例
6
4
0
#include<iostream>
#include<algorithm>
using namespace std;
struct BiNode {
char ch;
BiNode* lchirld, * rchirld;
};
class BiTree {
private:
BiNode* root;
BiNode* Create();
void Realse(BiNode* bt);
int CountDepth(BiNode* bt);
public:
BiTree() {
root = Create();
}
~BiTree() {
Realse(root);
}
int CountDepth() {
return CountDepth(root);
}
};
BiNode* BiTree::Create() {
BiNode* bt;
char ch;
cin >> ch;
if (ch == '#') bt = NULL;
else {
bt = new BiNode;
bt->ch = ch;
bt->lchirld = Create();
bt->rchirld = Create();
}
return bt;
}
void BiTree::Realse(BiNode* bt) {
if (!bt) return;
else {
Realse(bt->lchirld);
Realse(bt->rchirld);
delete bt;
}
}
int BiTree::CountDepth(BiNode* bt) {
if (!bt) return 0;
else {
int leftDepth = CountDepth(bt->lchirld);
int rightDepth = CountDepth(bt->rchirld);
return 1 + max(leftDepth, rightDepth);
}
}
int main()
{
int isContinue = 1;
while(isContinue)
{
BiTree tree;
cout << tree.CountDepth();
if(!tree.CountDepth()) isContinue = 0;
}
return 0;
}
本文来自博客园,作者:泥烟,CSDN同名, 转载请注明原文链接:https://www.cnblogs.com/Knight02/p/15799068.html