bzoj2763 飞行路线

2763: [JLOI2011]飞行路线

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 3273  Solved: 1260
[Submit][Status][Discuss]

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)

Output

只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

HINT

对于30%的数据,2<=n<=50,1<=m<=300,k=0;


对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;


对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.

分层图最短路+dp
d[i][j] : 点i经过了j次免费机会的最短路
分类讨论一下免费机会用不用的更新

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <cmath>
#include <cctype>
#include <string>
#include <cfloat>
#include <stack>
#include <cassert>
#include <bitset>

using namespace std;

const int N = 100010;

int head[N], to[N], rest[N], w[N], tot;

void add(int u, int v, int wi) {
    tot ++;
    to[tot] = v;
    w[tot] = wi;
    rest[tot] = head[u];
    head[u] = tot;
}

struct Node {
    int u, k;
};

queue<Node> q;

int inq[N][20], dis[N][20], n, m, k, s, t, ans;

int main() {
    scanf("%d%d%d%d%d", &n, &m, &k, &s, &t);
    s ++, t ++;
    for(int i = 1, u, v, w ; i <= m ; i ++) {
        scanf("%d%d%d", &u, &v, &w);
        u ++, v ++;
        add(u, v, w);
        add(v, u, w);
    }
    memset(dis, 0x3f, sizeof(dis));
    q.push((Node) {s, k});
    dis[s][k] = 0;
    inq[s][k] = 1;
    while(q.size()) {
        Node x = q.front();
        q.pop();
        int u = x.u, k = x.k;
        inq[u][k] = 0;
        for(int i = head[u] ; i ; i = rest[i]) {
            int v = to[i];
            if(dis[v][k] > dis[u][k] + w[i]) {
                dis[v][k] = dis[u][k] + w[i];
                if(!inq[v][k]) {
                    q.push((Node) {v, k});
                    inq[v][k] = 1;
                }
            }
            if(k && dis[v][k - 1] > dis[u][k]) {
                dis[v][k - 1] = dis[u][k];
                if(!inq[v][k - 1]) {
                    q.push((Node) {v, k - 1});
                    inq[v][k - 1] = 1;
                }
            }
        }
    }
    ans = 0x3f3f3f3f;
    for(int i = 0 ; i <= k ; i ++) {
        ans = min(ans, dis[t][i]);
    }
    printf("%d\n", ans);
}

  

posted @ 2017-09-12 15:05  KingSann  阅读(113)  评论(0编辑  收藏  举报