02-线性结构4 Pop Sequence

02-线性结构4 Pop Sequence(25 分)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:

YES
NO
NO
YES
NO

#include <iostream>
#include <malloc.h>
using namespace std;

typedef struct node
{
    int data;
    struct node *next;
}linkStack;

linkStack *createStack()
{
    linkStack *s;
    s=(linkStack *)malloc(sizeof(linkStack));
    s->next=NULL;
    return s;
}

int isEmpty(linkStack * s)
{
    return s->next==NULL;
}

void push(int item,linkStack *s)
{
    struct node *temCell;
    temCell=(linkStack *)malloc(sizeof(linkStack));
    temCell->data=item;
    temCell->next=s->next;
    s->next=temCell;
}

int pop(linkStack *s)
{
    if(isEmpty(s)) return NULL;
    else{
        int data;
        linkStack *first;
        first=(linkStack *)malloc(sizeof(linkStack));
        first=s->next;
        s->next=first->next;
        data=first->data;
        free(first);
        return data;
    }
}

int main()
{
    int m,n,k,num;
    cin>>m>>n>>k;
    int seques[n+1]={1};
    for(int i=0;i<k;i++){
        int j,cnt=0,isOrno=1;
        linkStack *s;
        s=createStack();
        for(j=0;j<n;j++){
            cin>>num;
            if(!isEmpty(s) && num<s->next->data){
                isOrno=0;
                break;
            }
            else{
                for(int i=1;i<=num;i++){
                    if(seques[i]){
                        push(i,s);
                        seques[i]=0;
                        cnt++;
                    }
                }
            }
            if(cnt>m){
                isOrno=0;
                break;
            }
            pop(s);
            seques[num]=0;
            cnt--;
        }
        if(isOrno) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
        while(j+1<n){
            cin>>num;
            j++;
        }
    }

    return 0;
}

posted @ 2017-10-20 22:20  ACLJW  阅读(150)  评论(0编辑  收藏  举报