2386:Lake Counting

总时间限制: 
1000ms
内存限制: 
65536kB
描述
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
输入
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
输出
* Line 1: The number of ponds in Farmer John's field.
样例输入
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
样例输出
3
提示
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
来源
USACO 2004 November

#include<cstdio>
using namespace std;
const int maxn = 200;
int n,m;
char Map[maxn][maxn];
void dfs(int x,int y){
    //Map[x][y] == '.';白痴BUG!!!
    Map[x][y] = '.';
    for(int dx=-1;dx<=1;dx++){
        for(int dy=-1;dy<=1;dy++){
            int newx = x + dx,newy = y + dy;
            if(0<=newx && newx<n && 0<=newy && newy<m && Map[newx][newy]=='W') dfs(newx,newy);
        }
    }
}
int main(){
    int cnt = 0;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++){
        scanf("%s",&Map[i]);
    }
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            if(Map[i][j] == 'W'){
                dfs(i,j);
                cnt++;
            }
        }
    }
    printf("%d\n",cnt);

    return 0;
}

posted @ 2018-03-15 00:46  ACLJW  阅读(215)  评论(0编辑  收藏  举报