3616:Milking Time

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12004 Accepted: 5067

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1000005,maxm = 1005;
struct interal{
    int sta;
    int en;
    int eff;
}interals[maxm];
int n,m,r,dp[maxm];
int cmp(interal a,interal b){
    return a.en < b.en;
}
void solve(){
    scanf("%d %d %d",&n,&m,&r);
    for(int i = 1;i <= m ;i++)
        scanf("%d %d %d",&interals[i].sta,&interals[i].en,&interals[i].eff);
    //从Interals[1]开始排序!!!
    sort(interals + 1,interals + m + 1,cmp);
    int Max = 0;
    //dp[i] 以第i段间隔为最后挤奶间隔
    for(int i = 1;i <= m;i++){
        dp[i] = interals[i].eff;
        for(int j = 1;interals[j].en + r <= interals[i].sta;j++){
            dp[i] = max(dp[i],dp[j] + interals[i].eff);
        }
        Max = max(Max,dp[i]);
    }
    printf("%d\n",Max);
}
int main()
{
    solve();
    return 0;
}

posted @ 2018-03-21 23:54  ACLJW  阅读(108)  评论(0编辑  收藏  举报