13040:All in All

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 34909 Accepted: 14571

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002

一定要记得每次重置字符串,不然会runtime error!

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100000 + 5;
char s[maxn],t[maxn];
int main(){
    while(scanf("%s %s",s,t) != EOF){
        int i = 0;
        for(int j = 0;t[j];j++){
            if(s[i] == t[j]) i++;
        }
        if(s[i]) printf("No\n");
        else printf("Yes\n");
        memset(s,'\0',sizeof(s));
        memset(t,'\0',sizeof(t));
    }
    return 0;
}

posted @ 2018-04-06 18:31  ACLJW  阅读(135)  评论(0编辑  收藏  举报