【动态规划】【数位DP】[PA 2015]Rownanie
题目描述
对于一个正整数 n,定义
1≤k,a,b≤10^18
a≤b
样例输入
51 5000 10000
样例输出
3
题目分析
可以发现当每一位都取9的时候答案最大,那么我们可以发现最大的平方和为
代码
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAXN = 9*9*18;
LL k, a, b;
LL solve(LL u){
LL n, sum, ret = 0;
for(LL i=1; i<=MAXN; i++){
n = i * k;
if(n > u) break;
sum = 0;
while(n){
sum += (n%10)*(n%10);
n /= 10;
}
if(sum == i)
ret ++;
}
return ret;
}
int main(){
scanf("%I64d%I64d%I64d", &k, &a, &b);
printf("%I64d\n", solve(b) - solve(a-1));
return 0;
}