PAT (Basic Level) Practice 1054 求平均值 内有干货,快来看 (!!!atof用法、stringstream注意事项、string变char* c_str()!!!)
1.题目
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
2.题目分析
1.stringstream的使用
stringstream ss;
int t;
for(int i=0;i<n;i++)
{
cin>>temp;
ss<<temp;
ss>>t;
if(ss.eof()&&!ss.fail())
{
//数字合法
}
ss.clear();
ss.str("");
}
第一点:
ss.eof() 会阻拦形如“22aas”的字符串,什么数字都不输出;而ss.fail()只要在遇到非法字符前存在数字也是可以转的,“22aas”结果就是22,而ss.fail()下“aaa22”的结果就是空.(ss.fail()未出问题返回0)
第二点:
在循环使用stringstream时,尽量保证只是用一个stringstream,不然 stringstream的构造、析构函数十分耗时间
而循环使用就必须在一次使用完毕之后进行清空,网上有的人说直接使用ss.clear()就🆗,其实不是的,那是瞎说祸害良民老百姓的!clear只是清空stringstream的状态(比如出错等),清空内容需要使用.str("")方法。例如下面的例子,开始输入aaa,转型失败无法输出,如果只是简单的clear,后面的2也无法输出!必须再使用str("")才行。
为了保险就两个都写了吧!
(只使用str("")也不行)
double t;
string temp ;
stringstream ss;
for (int i = 0; i < 2; i++)
{
cin >> temp;
ss << temp;
ss >> t;
if ( !ss.fail())
cout << t;
ss.clear();
ss.str("");
}
ss.clear();ss.str(""); //输入aaa 2 输出2
ss.str(""); //输入aaa 2 输出 空
ss.clear();//输入aaa 2 输出 空
2.atof()的使用(atoi转int同理)
1.需要添加头文件#include<cstdlib>
2.识别失败返回0 (所以再本题中我判断了为0的时候是不是0 0.0 0.00)例如下面的例子
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
float val;
char str[20];
strcpy(str, "98993489");
val = atof(str);
printf("字符串值 = %s, 浮点值 = %f\n", str, val);
strcpy(str, "runoob");
val = atof(str);
printf("字符串值 = %s, 浮点值 = %f\n", str, val);
return(0);
}
//字符串值 = 98993489, 浮点值 = 98993488.000000
//字符串值 = runoob, 浮点值 = 0.000000
3.假如识别“-3.2221.3” 结果并不是0!!!而是-3.22210!!!也是就说多个小数点会识别一个而不是都不识别!
4.string类型不能直接使用atof,要将string转换为char * 即使用c_str()函数
string a="521.1314";
double really=atof(a.c_str());
3.代码
1.stringstream版本
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<sstream>
#include<cstdlib>
using namespace std;
int main()
{
int n;
cin >> n;
string temp;
double t;
int count = 0;
double sum = 0;
stringstream ss;
for (int i = 0; i<n; i++)
{
cin >> temp;
ss << temp;
ss >> t;
if (temp.find('.') != string::npos && (temp.length() - temp.find_last_of('.') - 1>2))
{
printf("ERROR: %s is not a legal number\n", temp.c_str());
ss.str("");
ss.clear();
continue;
}
if (ss.eof()&&!ss.fail()&&t <= 1000 &&t >= -1000)
{
count++; sum += t;
}
else
printf("ERROR: %s is not a legal number\n", temp.c_str());
ss.str("");
ss.clear();
}
if (count == 0)
printf("The average of 0 numbers is Undefined\n");
else if(count==1)
printf("The average of %d number is %.2f", count, sum / count);
else
printf("The average of %d numbers is %.2f", count, sum/count);
return 0;
}
2.atof版本
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
int n;
cin >> n;
string temp;
double t;
int count = 0;
int count2 = 0;
double sum = 0;
for (int i = 0; i<n; i++)
{
count2 = 0;
cin >> temp;
for (int j = 0; j < temp.length(); j++)
if (temp[j] == '.')
count2++;
if (count2>1||(temp.find('.') != string::npos && (temp.length() - temp.find_last_of('.') - 1>2)))
{
printf("ERROR: %s is not a legal number\n", temp.c_str());
continue;
}
t = atof(temp.c_str());
if (t == 0 && temp != "0"&&temp != "0.0"&&temp != "0.00")
{
printf("ERROR: %s is not a legal number\n", temp.c_str()); continue;
}
if (t <= 1000 &&t >= -1000)
{
count++; sum += t;
}
else
printf("ERROR: %s is not a legal number\n", temp.c_str());
}
if (count == 0)
printf("The average of 0 numbers is Undefined\n");
else if(count==1)
printf("The average of %d number is %.2f", count, sum / count);
else
printf("The average of %d numbers is %.2f", count, sum/count);
return 0;
}