PAT (Advanced Level) Practice 1153 Decode Registration Card of PAT (25分)

1.题目

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

2.代码

#include<iostream>
#include <unordered_map>
#include<vector>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
	string t;
	int value;
};
	bool cmp(const node&a, const node&b)
	{
		if (a.value == b.value)return a.t < b.t;
		return a.value > b.value;
	}

int main()
{
	int n, m,temp,tt;
	string temp3;
	cin >> n >> m;
	string aa; 
	vector<node>list;
	for (int i = 0; i < n; i++)
	{
		cin >> aa >> temp;
		struct node n1;
		n1.t = aa; n1.value = temp;
		list.push_back(n1);
	}
	

	for (int i = 0; i < m; i++)
	{
		int count = 0, total = 0;
		vector<node>out;
		cin >> temp >> temp3;
		printf("Case %d: %d %s\n", i + 1, temp, temp3.c_str());
		if (temp == 1)
		{
			for (int j = 0; j < list.size(); j++)
			{
				if (list[j].t[0] == temp3[0])
					out.push_back(list[j]);
			}
		}
		else if (temp == 2)
		{
			for (int j = 0; j < list.size(); j++)
			{
				if (list[j].t.substr(1, 3) ==temp3)
				{
					count++; total += list[j].value;
				}
			}
			if(count!=0)printf("%d %d\n", count, total);
		}
		else if (temp == 3)
		{
			unordered_map<string, int>out2;
			for (int j = 0; j < list.size(); j++)
			{
				if (list[j].t.substr(4, 6) ==temp3)
				{
					out2[list[j].t.substr(1,3)]++;
				}
			}
			for (auto it = out2.begin(); it != out2.end(); it++)
				out.push_back({ it->first, it->second });
		}
		
		if (((temp == 1 || temp == 3) && out.size() == 0 || (temp == 2 && count == 0)))
		{
			printf("NA\n"); continue;
		}
		sort(out.begin(), out.end(), cmp);
		for (int k = 0; k < out.size(); k++)
		{
			printf("%s %d\n", out[k].t.c_str(), out[k].value);
		}
		
	}




}

 

posted @ 2020-03-23 10:39  Jason66661010  阅读(94)  评论(0编辑  收藏  举报