PAT (Advanced Level) Practice 1115 Counting Nodes in a BST (30分) (不用BFS、DFS、不用遍历直接建树标记完事)
1.题目
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than or equal to the node's key.
- The right subtree of a node contains only nodes with keys greater than the node's key.
- Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.
Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:
n1 + n2 = n
where n1
is the number of nodes in the lowest level, n2
is that of the level above, and n
is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
2.题目分析
建树的时候加上层数概念,题目中求的是二叉搜索树的最下面一行以及这一行的上一行,我设根节点深度为0,即输出深度最大以及第二大的节点个数就行(使用map标记,无需遍历)
3.代码
#include<iostream>
#include<map>
using namespace std;
typedef struct node * tree;
struct node
{
int data;
tree left;
tree right;
};
map<int,int>levels;
tree creat(tree t, int x,int level)
{
if (!t)
{
t = (tree)malloc(sizeof(struct node));
t->data = x;
t->left = t->right = NULL;
levels[level]++;
return t;
}
if (t->data < x)
t->right = creat(t->right, x, level + 1);
else
t->left = creat(t->left, x, level + 1);
return t;
}
int main()
{
int n,a;
scanf("%d", &n);
tree t = NULL;
for (int i = 0; i < n; i++)
{
scanf("%d", &a);
t = creat(t, a, 0);
}
int size = levels.size();
printf("%d + %d = %d\n", levels[size - 1], levels[size - 2], levels[size - 1] + levels[size - 2]);
}