PAT (Advanced Level) Practice 1108 Finding Average (20分)
1.题目
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.
Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number
where X
is the input. Then finally print in a line the result: The average of K numbers is Y
where K
is the number of legal inputs and Y
is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined
instead of Y
. In case K
is only 1, output The average of 1 number is Y
instead.
Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
2.代码
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<sstream>
#include<cstdlib>
using namespace std;
int main()
{
int n;
cin >> n;
string temp;
double t;
int count = 0;
double sum = 0;
stringstream ss;
for (int i = 0; i<n; i++)
{
cin >> temp;
ss << temp;
ss >> t;
if (temp.find('.') != string::npos && (temp.length() - temp.find_last_of('.') - 1>2))
{
printf("ERROR: %s is not a legal number\n", temp.c_str());
ss.str("");
ss.clear();
continue;
}
if (ss.eof()&&!ss.fail()&&t <= 1000 &&t >= -1000)
{
count++; sum += t;
}
else
printf("ERROR: %s is not a legal number\n", temp.c_str());
ss.str("");
ss.clear();
}
if (count == 0)
printf("The average of 0 numbers is Undefined\n");
else if(count==1)
printf("The average of %d number is %.2f", count, sum / count);
else
printf("The average of %d numbers is %.2f", count, sum/count);
return 0;
}