PAT (Advanced Level) Practice 1074 Reversing Linked List (25分)
1.题目
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
2.题目分析
PAT (Basic Level) Practice 1025 反转链表 (25分) (链表的反转 使用栈 / reverse函数)
3.代码
#include<iostream>
#include<algorithm>
using namespace std;
#define max 100011
struct node
{
int address;
int data;
int next;
} sorts[max], list[max];
int main()
{
int start, n, k;
cin >> start >> n >> k;
int temp;
for (int i = 0; i < n; i++)
{
cin >> temp;
cin >> list[temp].data;
cin >> list[temp].next;
list[temp].address = temp;
}
int total = 0;
int count = 0;
while (start != -1)
{
total++;
sorts[count++] = list[start];
start = list[start].next;
}
for (int i = 0; i < total / k; i++)
reverse(sorts + i*k, sorts + i*k + k);
int i = 0;
for ( i = 0; i < total - 1; i++)
printf("%05d %d %05d\n", sorts[i].address, sorts[i].data, sorts[i + 1].address);
printf("%05d %d -1\n", sorts[i].address, sorts[i].data, sorts[i + 1].address);
}