AGC 025 B - RGB Coloring

B - RGB Coloring


Time limit : 2sec / Memory limit : 1024MB

Score : 700 points

Problem Statement

Takahashi has a tower which is divided into N layers. Initially, all the layers are uncolored. Takahashi is going to paint some of the layers in red, green or blue to make a beautiful tower. He defines the beauty of the tower as follows:

  • The beauty of the tower is the sum of the scores of the N layers, where the score of a layer is A if the layer is painted red, A+B if the layer is painted green, B if the layer is painted blue, and 0 if the layer is uncolored.

Here, A and B are positive integer constants given beforehand. Also note that a layer may not be painted in two or more colors.

Takahashi is planning to paint the tower so that the beauty of the tower becomes exactly K. How many such ways are there to paint the tower? Find the count modulo 998244353. Two ways to paint the tower are considered different when there exists a layer that is painted in different colors, or a layer that is painted in some color in one of the ways and not in the other.

Constraints

  • 1≤N≤3×105
  • 1≤A,B≤3×105
  • 0≤K≤18×1010
  • All values in the input are integers.

Input

Input is given from Standard Input in the following format:

N A B K

Output

Print the number of the ways to paint tiles, modulo 998244353.


Sample Input 1

Copy
4 1 2 5

Sample Output 1

Copy
40

In this case, a red layer worth 1 points, a green layer worth 3 points and the blue layer worth 2 points. The beauty of the tower is 5 when we have one of the following sets of painted layers:

  • 1 green, 1 blue
  • 1 red, 2 blues
  • 2 reds, 1 green
  • 3 reds, 1 blue

The total number of the ways to produce them is 40.


Sample Input 2

Copy
2 5 6 0

Sample Output 2

Copy
1

The beauty of the tower is 0 only when all the layers are uncolored. Thus, the answer is 1.


Sample Input 3

Copy
90081 33447 90629 6391049189

Sample Output 3

Copy
577742975


pkusc之后非常难过qwq,刷道水题安慰自己qwq。
(这可能是组合计数模板题??)

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<ctime>
#define ll long long
using namespace std;
const int maxn=300005,ha=998244353;
inline void add(int &x,int y){ x+=y; if(x>=ha) x-=ha;}
inline int ksm(int x,int y){
	int an=1;
	for(;y;y>>=1,x=x*(ll)x%ha) if(y&1) an=an*(ll)x%ha;
	return an; 
}

int jc[maxn],ni[maxn];
int N,A,B,ans;
ll K;

inline int C(int x,int y){ return jc[x]*(ll)ni[y]%ha*(ll)ni[x-y]%ha;}

inline void init(){
	jc[0]=1;
    for(int i=1;i<=N;i++) jc[i]=jc[i-1]*(ll)i%ha;
    ni[N]=ksm(jc[N],ha-2);
    for(int i=N;i;i--) ni[i-1]=ni[i]*(ll)i%ha;
}

inline void solve(){
	const int b=B,T=min((ll)N,K/A);
	
	for(int i=0;i<=T;i++){
		if((K-A*(ll)i)%b) continue;
		ll lef=(K-A*(ll)i)/b;
		if(lef>N) continue;
		
		add(ans,C(N,i)*(ll)C(N,lef)%ha);
	}
}

int main(){
	scanf("%d%d%d%lld",&N,&A,&B,&K);
	
	init(),solve();
	
	printf("%d\n",ans);
	return 0;
}

  

posted @ 2018-06-05 09:49  蒟蒻JHY  阅读(357)  评论(0编辑  收藏  举报