[SDOI2016]生成魔咒

4516: [Sdoi2016]生成魔咒

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 1460  Solved: 835
[Submit][Status][Discuss]

Description

魔咒串由许多魔咒字符组成,魔咒字符可以用数字表示。例如可以将魔咒字符 1、2 拼凑起来形成一个魔咒串 [1,2]。
一个魔咒串 S 的非空字串被称为魔咒串 S 的生成魔咒。
例如 S=[1,2,1] 时,它的生成魔咒有 [1]、[2]、[1,2]、[2,1]、[1,2,1] 五种。S=[1,1,1] 时,它的生成魔咒有 [1]、
[1,1]、[1,1,1] 三种。最初 S 为空串。共进行 n 次操作,每次操作是在 S 的结尾加入一个魔咒字符。每次操作后都
需要求出,当前的魔咒串 S 共有多少种生成魔咒。
 

Input

 

第一行一个整数 n。
第二行 n 个数,第 i 个数表示第 i 次操作加入的魔咒字符。
1≤n≤100000。,用来表示魔咒字符的数字 x 满足 1≤x≤10^9

Output

输出 n 行,每行一个数。第 i 行的数表示第 i 次操作后 S 的生成魔咒数量

 

Sample Input

7
1 2 3 3 3 1 2

Sample Output

1
3
6
9
12
17
22

HINT

 

Source

 
 
后缀自动机裸题,,,,
/**************************************************************
	Problem: 4516
	User: JYYHH
	Language: C++
	Result: Accepted
	Time:792 ms
	Memory:14936 kb
****************************************************************/

#include<bits/stdc++.h>
#define ll long long
#define maxn 200005
using namespace std;
map<int,int> ch[maxn];
int n,m,cnt=1,pre=1,k;
int l[maxn],f[maxn];
ll ans=0;

inline void ins(int x){
	int p=pre,np=++cnt;
	pre=np,l[np]=l[p]+1;
	
	for(;p&&!ch[p].count(x);p=f[p]) ch[p][x]=np;
	if(!p) f[np]=1;
	else{
		int q=ch[p][x];
		if(l[q]==l[p]+1) f[np]=q;
		else{
			int nq=++cnt;
			l[nq]=l[p]+1;
			ch[nq]=ch[q];
			ans-=(ll)l[q]-l[f[q]];
			f[nq]=f[q];
			f[q]=f[np]=nq;
			ans+=(ll)l[q]-l[f[q]];
			ans+=(ll)l[nq]-l[f[nq]];
			
			for(;ch[p][x]==q;p=f[p]) ch[p][x]=nq;
		}
	}
	
	ans+=(ll)l[np]-l[f[np]];
}

int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&k);
		ins(k);
		printf("%lld\n",ans);
	}
	
	return 0;
}

  

posted @ 2018-03-04 15:58  蒟蒻JHY  阅读(483)  评论(0编辑  收藏  举报