D - Equals
D - Equals
Problem Statement
We have a permutation of the integers from 1 through
Choose j such that
Find the maximum possible number of i such that pi=i after operations.
Constraints
p is a permutation of integers from
If
All values in input are integers.
Input
Input is given from Standard Input in the following format:
N M
p1 p2 .. pN
x1 y1
x2 y2
:
xM yM
Output
Print the maximum possible number of i such that pi=i after operations.
Sample Input 1
5 2
5 3 1 4 2
1 3
5 4
Sample Output 1
2
If we perform the operation by choosing j=1, p becomes 1 3 5 4 2, which is optimal, so the answer is 2.
Sample Input 2
3 2
3 2 1
1 2
2 3
Sample Output 2
3
If we perform the operation by, for example, choosing j=1, j=2, j=1 in this order, p becomes 1 2 3, which is obviously optimal. Note that we may choose the same j any number of times.
Sample Input 3
10 8
5 3 6 8 7 10 9 1 2 4
3 1
4 1
5 9
2 5
6 5
3 5
8 9
7 9
Sample Output 3
8
Sample Input 4
5 1
1 2 3 4 5
1 5
Sample Output 4
5
We do not have to perform the operation.
题意
通过无限次操作
思路
将可以交换的位置用并查集合成一个集合,遍历一遍数组,如果
代码
点击查看代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;
#define X first
#define Y second
typedef pair<int,int> pii;
typedef long long LL;
const char nl = '\n';
const int N = 2e5+10;
const int M = 2e5+10;
int n,m;
int a[N],p[N];
int find(int x){
if(p[x] != x)p[x] = find(p[x]);
return p[x];
}
void solve(){
cin >> n >> m;
for(int i = 1; i <= n; i ++ ){
cin >> a[i];
p[i] = i;
}
while(m --){
int a,b;
cin >> a >> b;
p[find(a)] = find(b);
}
int ans = 0;
for(int i = 1; i <= n; i ++ ){
if(find(i) == find(a[i]))ans ++;
}
cout << ans << nl;
}
int main(){
ios::sync_with_stdio(false);
cin.tie(0),cout.tie(0);
solve();
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 地球OL攻略 —— 某应届生求职总结
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 提示词工程——AI应用必不可少的技术
· .NET周刊【3月第1期 2025-03-02】