SGU[115] Calendar

Description

描述

First year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

千禧年过后的第一年已经过去了。为了纪念它,请你写一个程序来计算2001年中任何一天的星期。

 

Input

输入

Input is a line with two positive integer numbers N and M, where N is a day number in month MN and M is not more than 100.

输入文件包含两个正整数N、M,表示第M月的第N天。其中N、M均不会超过100。


Output

输出

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

输出当天的星期对应的数字(星期一 - 1, ···,星期天 - 7),如果输入的日期不合法,输出“Impossible”。


Sample Input

样例输入

21 10


Sample Output

样例输出

7

 

Analysis

分析

翻看日历,我们可以知道2001年1月1日为星期一。

这样,我们只需要计算输入的日期为该年中的第几天就行了。

当然,要记得判断输入的日期是否合法。

 

Solution

解决方案

#include <iostream>

using namespace std;

const int pDay[] = { 0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 };

int main()
{
	int N, M, ans = 0;
	cin >> N >> M;
	if((M > 12 || N > 31) || 
		(M == 4 || M == 6 || M == 9 || M == 11) && N > 30 || 
		M == 2 && N > 28)
	{
		cout << "Impossible" << endl; 
	}
	else
	{
		for(int i = 1; i < M; i++)
		{ ans += pDay[i]; }
		ans += N;
		cout << (ans % 7 == 0 ? 7 : ans % 7) << endl;
	}
	return 0;
}

 

这道题目是关于日期处理的,也是非常常见的题型。

posted @ 2015-01-29 21:18  Ivy_End  阅读(131)  评论(0编辑  收藏  举报