AC日记——统计难题 hdu 1251

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 36637    Accepted Submission(s): 13622


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

 

Sample Input
banana band bee absolute acm ba b band abc
 

 

Sample Output
2 3 1 0
 

 

Author
Ignatius.L
 

 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1075 1247 1671 1298 1800 
 
思路:
  裸tire树;
 
来,上代码:
#include <string>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

struct TreeNode {
    short num;
    bool if_[26];
    struct TreeNode *word[26];
};

class TrieTreeType {
    private:
        struct TreeNode *null;
    
    public:
        struct TreeNode *root;
        
        TrieTreeType()
        {
            null=new TreeNode;
            null->num=0;
            for(int i=0;i<=25;i++) null->if_[i]=false;
            for(int i=0;i<=25;i++) null->word[i]=null;
            root=new TreeNode;
            root->num=0;
            for(int i=0;i<=25;i++) root->if_[i]=false;
            for(int i=0;i<=25;i++) root->word[i]=null;
        }
        
        inline void Insert(char str[])
        {
            TreeNode *now=root;
            now->num++;
            int len=strlen(str);
            for(int v=0;v<len;v++)
            {
                if(!now->if_[str[v]-'a'])
                {
                    now->word[str[v]-'a']=new TreeNode;
                    now->word[str[v]-'a']->num=0;
                    for(int i=0;i<=25;i++) now->word[str[v]-'a']->if_[i]=false;
                    for(int i=0;i<=25;i++) now->word[str[v]-'a']->word[i]=null;
                    now->if_[str[v]-'a']=true;
                }
                now=now->word[str[v]-'a'];
                now->num++;
            }
        }
        
        inline int Size(char str[])
        {
            TreeNode *now=root;
            int len=strlen(str);
            for(int v=0;v<len;v++)
            {
                if(now->word[str[v]-'a']==null) return 0;
                now=now->word[str[v]-'a'];
            }
            return now->num;
        }
};
class TrieTreeType tree;

int len_sen,n;

char sen[11];

bool if_c=false;

int main()
{
    while(gets(sen))
    {
        if(strlen(sen)==0)
        {
            if_c=true;
            continue;
        }
        if(if_c) printf("%d\n",tree.Size(sen));
        else tree.Insert(sen);
    }
    return 0;
}

 

posted @ 2017-01-16 10:44  IIIIIIIIIU  阅读(137)  评论(0编辑  收藏  举报