12周作业

这个作业属于哪个课程 C语言程序设计Ⅱ
这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class2-2018/homework/3234
我在这个课程的目标是 理解指针数组,二级指针,函数指针
这个作业在哪个具体方面帮助我实现目标 指针与数组,函数,结构的联系
参考文献 C语言程序设计第11章

6-1 计算最长的字符串长度 (15 分)

本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

实验代码

int max_len( char *s[], int n )
{	
      int max=0; 	
      int u;		
        for(u=0;u<n;u++){		
        if(strlen(s[max])<strlen(s[u]))
        {			
          max=u;			
        }	
                        }		
return strlen(s[max]);
} 

实验思路: 定义一个变量给初始值为0;在strlen函数中看是否(s[max])<strlen(s[u]),是就把u赋值max,否则u加1,再次比较,直到u大于等于n或满足(s[max])<strlen(s[u]))结束循环,输出strlen(s[max])

正确截图:

流程图:
6-2 统计专业人数 (15 分)

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
    char code[8];
    struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表  例:*struct node* createlist()这是一个函数,返回类型是struct node*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

int countcs( struct ListNode *head )
{
    int i = 0;
    while(head)
    {
        if(head->code[1] == '0' && head->code[2] == '2')
            i++;
        head = head->next;
    }
    return i;
}

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:

3

实验思路: 自定义函数在指针函数中找出第二位和第三位为02的编号,满足条件加1。返回他的值,输出.
正确截图:

流程图:

6-3 删除单链表偶数节点 (20 分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

struct ListNode *createlist(){   
    int x;
    struct ListNode *head,*tail,*p;
    head=(struct ListNode*)malloc(sizeof(struct ListNode));
    head->next=NULL; 
    tail=head; 
       while(1)    { 
       p=(struct ListNode*)malloc(sizeof(struct ListNode));
      p->next=NULL;
      scanf("%d",&x); 
           if(x==-1)
            break;
        p->data=x; 
        p->next=NULL; 
        tail->next=p; 
        tail=p; 
           }       
        return head;
         } 
        struct ListNode *deleteeven( struct ListNode *head ){    
            struct ListNode *p1,*p2;    
            int flag;      
            p1=head;    
            p2=p1->next;    
            while(p1->next)    {        
                flag=0;        
                if(p2->data%2==0)       
                {            
                   p1->next=p2->next; 
                   p2=p2->next;            
                   flag=1;       
                 }        
                 if(flag==0)        
                 {            
                     p1=p1->next;            
                     p2=p1->next;        
                     }    
                     }        
                     return head->next;
}

实验思路: 和书上例题稍微类似,他这里是俩个函数一个函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。一个函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
正确截图:
流程图:

结对感想;有些东西就是得自己去找答案,然后去从别人那里去学习,书上的东西也不是每个地方都懂.

函数名带括号带指针的就是函数指针,否则就是指针函数
p=(int)malloc(sizeof(int)(n+1))是sizeof(int)(n+1) 是求一个字节数的过程
sizeof(int)就是int类型的字节数,再
(n+1),其实就是连续的n+1个int型数的空间所含的字节数
前面二者合起来就是分配了大小为n+1个int型的空间所含的字节数


posted @ 2019-05-16 23:23  我畏时光不惧  阅读(251)  评论(0编辑  收藏  举报