HDU 1232 畅通工程 并查集

畅通工程
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说 
3 3 
1 2 
1 2 
2 1 
这种输入也是合法的 
当N为0时,输入结束,该用例不被处理。 
 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 
 Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output

1 0 2 998

Hint

Hint  Huge input, scanf is recommended.
 
 
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn=1005;

int father[maxn],Rank[maxn];
int n,m;
int count;

void Init(int n)
{
    for(int i=1;i<=n;i++)
    {
        father[i]=i;
        Rank[i]=1;
    }
}

int Find(int x)
{
    if(x!=father[x])
    {
        father[x]=Find(father[x]);
    }
    return father[x];
}

void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x==y)
        return;
    if(Rank[x]>=Rank[y])
    {
        father[y]=x;
        Rank[x]+=Rank[y];
    }
    else
    {
        father[x]=y;
        Rank[y]+=Rank[x];
    }
}

int main()
{
    //freopen("input.txt","r",stdin);
    while(~scanf("%d",&n)&&n!=0)
    {
        Init(n);
        scanf("%d",&m);
        int a,b;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        count=0;
        for(int i=1;i<=n;i++)
        {
            if(i==father[i])
                count++;
        }
        printf("%d\n",count-1);
    }
}

  

 

posted @ 2016-07-26 23:17  Hyouka  阅读(175)  评论(0编辑  收藏  举报