A1009 Product of Polynomials[简单模拟--多项式相乘]

009 Product of Polynomials (25 分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6
————————————————-—————————
和A1002 异曲同工之处,有点堆排序的意思。

#include<iostream>
using namespace std;
double p[2002];
struct node
{
	int zhishu;
	double xishu;
}poly[1001];
double ans[2002];
int main()
{
	int n,m, count = 0;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> poly[i].zhishu >> poly[i].xishu;
	}
	cin >> m;
	for (int i = 0; i < m; i++)
	{
		int zhishu; double xishu;
		cin >> zhishu >> xishu;
		for (int j = 0; j < n; j++)
			ans[zhishu + poly[j].zhishu] += (xishu * poly[j].xishu);
	}
	for (int i = 0; i < 2002; i++)
	{
		if(ans[i] != 0)
		count++;
	}
	cout << count;
	for (int i = 2001; i >=0; i--)
	{
		if (ans[i] != 0.0)
			printf(" %d %.1f", i, ans[i]);
	}
}
posted @ 2020-06-20 11:28  _Hsiung  阅读(56)  评论(0编辑  收藏  举报