A1027 Colors in Mars[简单模拟--进制转换]

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input
15 43 71
Sample Output
#123456

  1. 属于一道简单的进制转换题,需要掌握点技巧,黄色的话要注意。
#include<iostream>
using namespace std;
char radix[13] = { '0','1','2','3','4','5','6','7','8','9','A','B','C' };
int z[6] = { 0 };
int jinzhi(int n)
{
	int num = 0;
	while (n != 0)
	{
		z[num++] = n % 13;
		n /= 13;
	}
	return num - 1;
}

int main()
{
	int n1, n2, n3;
	cin >> n1 >> n2 >> n3;
	cout << "#";
	int a=jinzhi(n1);
	int i = 1 - a;
	for (int j = i; j > 0; j--)
	{
		cout << "0";
	}
	while (a != -1)
	{
		cout << radix[z[a]];
		a--;
	}
	a = jinzhi(n2);
	i = 1 - a;
	for (int j = i; j > 0; j--)
	{
		cout << "0";
	}
	while (a != -1)
	{
		cout << radix[z[a]];
		a--;
	}
	a = jinzhi(n3);
	i = 1 - a;
	for (int j = i; j > 0; j--)
	{
		cout << "0";
	}
	while (a != -1)
	{
		cout << radix[z[a]];
		a--;
	}
	

}
posted @ 2020-06-28 15:19  _Hsiung  阅读(60)  评论(0编辑  收藏  举报