~欢迎你!第 AmazingCounters.com 位造访者

poj 2559 Largest Rectangle in a Histogram - 单调栈

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19782   Accepted: 6393

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.
 
/*/
大二这学期开学真是忙爆了。作为一个班干部,天哪。。

好久没有刷题了,想起以前听了岛娘的一节课,单调栈,好像有点似懂非懂,于是抽时间看了一下,总算是搞通了。。。

将读入的数据一个个压栈,奖数据与栈顶进行比较大小,如果这个数比栈顶小,就计算以站顶为高的最大矩形的大小,弹出栈顶。如果这个数比栈顶大,直接就压进栈。这样一系列操作之后,就会发现栈里面剩下一个递增数列,用一个pair来保存此时栈高度和前面达到这个高度的个数,然后按照前面的思想去计算每一个高度最大矩形面积是多大。

AC代码: /*/

#include "stdio.h"
#include "string.h"
#include "stack"
#include "algorithm"
using namespace std;
typedef long long LL;
typedef pair<LL,LL> PII;
const LL MX = 1e5 + 5;
int main() {
	LL n,h;
	while(~scanf("%lld",&n)) {
          if(n==0)break; stack<PII> Q; while(!Q.empty()) { Q.pop(); } LL ans=0; for(LL i=0; i<n; i++) { scanf("%lld",&h); LL Now_Big_W=0; while(!Q.empty() && Q.top().first >= h ) { LL H = Q.top().first; LL W = Q.top().second; Q.pop(); Now_Big_W+=W; ans=max(ans,H*Now_Big_W); } Q.push(PII(h,Now_Big_W+1)); } LL The_number_W=0; while(!Q.empty()){ The_number_W+=Q.top().second; ans=max(ans,Q.top().first*The_number_W); Q.pop(); } printf("%lld\n",ans); } return 0; }

  

  

posted @ 2016-10-21 01:19  ~HDMaxfun  阅读(375)  评论(0编辑  收藏  举报